Discussie Dubbele vermelding in Master Boot Record

Prutser

Heeft veel posts
Gisteren na een geplande stroomonderbreking wilde mij pc niet meer opstarten, omdat er geen besturingssysteem aanwezig zou zijn.
Dit heb ik opgelost met de Windows 10 herstel dvd middels het herstellen van MBR
Omdat ik een dual systeem heb, moest ik ook Grub opnieuw instellen, dit heb ik gedaan met Linux mint 19 dvd.
Nu blijkt Windows 10, twéé keer in MBR te staan, maakt niet uit welke ik neem, Windows start normaal op.
Kan ik één van beide verwijderen, zo ja, hoe doe ik dat.

Windows MBR.jpg
 

Prutser

Heeft veel posts
Nou, zo zag ik dat ook, alleen is dat niet zo. Windows staat op een SSD.
Op een partitie van HDD staat verder geen ander besturing systeem dan Linux.

Nou heb ik zojuist iets gevonden wat net zo iets is, maar dan met W 7

 
Laatst bewerkt:

Prutser

Heeft veel posts
Ik kan met Grub Customizer één en ander weg halen, in het artikel raad men dat trouwens sterk af.
Het 2e item, SDA 2, is dus door Boot-Repair toegevoegd, voor de veiligheid, als opstarten via SDA1 niet zou lukken!
Ik laat het maar zo.

Dank voor je reactie.
 

Abraham54

Admin
Team lid
Inderdaad is Grub Custimizer absoluut uit den boze om Grub te veranderen.

Dat kan wel gewoon in Linux, maar omdat ik momenteel Mint nog weer moet herinstalleren kan ik je daarbij nog niet op eenvoudige wijze helpen.
Ik denk dat ik morgen Mint weer installeer en daarna tweak en dan kan ik jou of morgen of overmorgen helpen om het Grubvenster aan te passen.
 

Abraham54

Admin
Team lid
@Prutser - Linux Mint is weer aanwezig in mijn notebook.
Maar toch wil ik graag dat je nu eerst iets in Windows naspeurt.

  • Druk de Windowstoets en de R-toets tegelijkertijd in.
  • Het venster Uitvoeren zal zichtbaar worden.
  • Geef als opdracht nu msconfig en druk op de Entertoets of de knop OK
  • Klik in het Hulpprogramma voor Systeemconfiguratie op de tab Opstarten en wat staat er bij jou vermeld?

 

Abraham54

Admin
Team lid
Oké, ik ga zo weer naar Linux gaan, dan wil ik weten wat jij allemaal in het Grub-bestand hebt staan!
 

Abraham54

Admin
Team lid
Als jij in Linux zit - doe dan het volgende:

open een terminal venster en geef als opdracht xed admin:///etc/default/grub
Daarbij wordt dan jouw wachtwoord gevraagd.

Selekteer alles wat in het Grub-document staat, kopieer het dan en plak het dan in jouw volgende bericht.
Daarna mag jet Grub-document weer sluiten.
 

Prutser

Heeft veel posts
GRUB_DEFAULT="0"
GRUB_TIMEOUT_STYLE="hidden"
GRUB_TIMEOUT="10"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE="640x480"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
 

Abraham54

Admin
Team lid
Helemaal goed!

Als je wil dat Windows automatisch opstart in plaats van Linux Mint,

Moet je bij GRUB_DEFAULT="0" de nul in een 4 veranderen!

Sla het bestand dan op en daarna moet je Grub updaten!

Dat doe je weer via de Terminal met het commando: sudo update-grub

Waarom Grub tweemaal Windows aanduidt, blijft een raadsel.

Mogelijk dat je bij de reparatie van Grub de C-schijf als boot het aangegeven maar aan de andere kant is het ook geen probleem.
 

Prutser

Heeft veel posts
Dat zou ik inderdaad nog kunnen veranderen, zodat zonder een keuze gemaakt te hebben, Windows opstart.
Tijdens de reparatie heb ik zeker geen C(SSD) als boot opgegeven, steeds werd de HDD als keus aangegeven.
Wellicht is 2x reparatie, de oorzaak?
 
Bovenaan Onderaan