Te Koop XenForo probleem na verhuizing.

Abraham54

Admin
Team lid
@Cédric Vleminckx

Helaas heb jij nog geen topic aangemaakt, ik heb ondertussen meer gevonden.

Onderstaande afbeelding heb jij op op het communityforum van XenForo gepost:



Verder heb jij aangegeven dat dit ontstaan is nadat jij van host bent veranderd.
Je hebt op XenForo aangegeven dat ook de database via export en import is overgezet.
Dus feitelijk moet alles in orde zijn.
Wat ik zie, kan te maken hebben met een corrupt thema bestand.
 
V

Verwijderd forumlid 175

Guest
Volgens mij heeft de TS de verhuis verkeerd uitgevoerd .
 

Abraham54

Admin
Team lid
Al;s de verhuizing verkeerd zou zijn gegaan (jouw optiek) zou bovenstaande afbbeelding ook niet gemaakt kunnen worden.
Dist is de HTML-weergave van de betreffende pagina.
Xenforo werkt wel degelijk anders dan bijv. phpBB.
 
V

Verwijderd forumlid 175

Guest
Wat bedoel ik met verkeerd uitvoeren zoals ik het van sommigen al heb gezien .
Ze maken een backup van hun domein en exporteren de database .
Op de nieuwe server zetten ze de backup en database terug en dan bekom je wat in de afbeelding te zien is in het startbericht .
De juiste wijze is op de nieuwe server database aanmaken
Forum installeren, database leegmaken en de ge exporteerde database importeren en je forum staat netjes terug zoals op de vorige server .
 

Abraham54

Admin
Team lid
Dan heb jij een heel andere wijze van exporteren en herinrichten dan ik dat doe en en het gros van de anderen die dit ook met succes hebben gedaan.
Want doe je het op jou manier ben je bijvoorbeeld alle geuploade bestanden kwijt, de avatars van de leden zijn er niet meer en ga zo maar door.
 
V

Verwijderd forumlid 175

Guest
Want doe je het op jou manier ben je bijvoorbeeld alle geuploade bestanden kwijt, de avatars van de leden zijn er niet meer en ga zo maar door.
Die bevinden zich toch in de database , en ben je dan toch niet kwijt .
 
V

Verwijderd forumlid 175

Guest
Hoe exporteer en importeer jij dan je database .
Hoe infecteer je een database ? Door een besmette bijlage naar de database te uploaden !
 

Abraham54

Admin
Team lid
Wat haal jij er toch weer rare dingen bij.
Ik doe het zoals het gedaan behoort te doen.
Op die wijze heb ik het NCF ook uit Engeland naar een Nederlandse host overgezet en gemigreerd naar XenForo.
 
V

Verwijderd forumlid 175

Guest
Ik haal er niets vreemds bij . Ik wil juist aantonen dat bijlagen worden opgenomen in de database .
Op die wijze heb ik het NCF ook uit Engeland naar een Nederlandse host overgezet en gemigreerd naar XenForo.
Migreren is dan al iets helemaal anders . Je hebt het NCF forum gemigreerd van Vbulletin naar Xenforo en dan verhuisd . Bij migreren kunnen avatars en bijlagen verloren gaan .
 

Abraham54

Admin
Team lid
Gemigreerd naar XenForo is op de Nederlandse server gebeurd, omdat de Engelse host het ons verbood op die server naar XenForo te gaan!
En afbeeldingen worden in een map op de server opgeslagen.
Jouw phoBB forum heeft bijv op de server een map "images" waarin bijv. de map "avatars" zit.
Dat de database in de usersectie bij users heeft staan welke avatar zij gebruiken - alas, maar afbeeldingen kunnen niet opgeslagn worden in de database.
 

Black Tiger

Enthousiast
Dist is de HTML-weergave van de betreffende pagina.
Dan vraag ik me af of php wel goed werkt. Wat hij eens kan proberen is een phpinfo.php pagina te maken en te zien of deze gewoon op te roepen is. Ik ben ooit bij een host geweest (voordat ik alles zelf regelde) waar ik het volgende in een .htaccess moest zetten om e.e.a. werkend te krijgen:
Code:
AddHandler application/x-httpd-php .html
AddType application/x-httpd-php .html
Dus dat is ook nog een optie, naast inderdaad een thema wat misschien niet goed werkt.

Voor de rest zou dit probleem vrij eenvoudig op te lossen moeten kunnen zijn door naar de apache logfiles te kijken.

Verwijderd forumlid 175 zei:
Ik wil juist aantonen dat bijlagen worden opgenomen in de database .
Dat is bij veel forum software een keuze mogelijkheid. Persoonlijk vind ik dit een onverstandige keuze. Reden: Als je veel van bijlages gebruik maakt kan de database hierdoor enorm groot worden. Dit kan zelfs het backuppen van de database voor een gewone klant zonder SSH toegang problematisch maken, idem het uploaden. Dit o.a. door bepaalde tijdsbeperkingen in de php.ini van de host.
Het is beter om bijlages buiten de database op te slaan, dus gewoon gebruik maken van het bestandssysteem. Je moet immers toch een goede backup maken zoals Abraham54 omschrijft, om bijv. custom avatars mee te kunnen nemen in de backup en images (afbeeldingen) die men zelf toegevoegd heeft.
 
Laatst bewerkt door een moderator:

Cédric Vleminckx

Junior lid
Hallo allemaal,

Hier ben ik al maar weer even.

Ik zit inderdaad bij one.com, en ik heb hen gekozen omdat ik meerdere websites heb bij hen, en ik daar zeer tevreden over ben. Ik heb nog nooit een probleem met hen gehad.

Ik heb dus het Xenforo forum verhuist, de files via FTP, en de database heb ik bij de vorige host geëxporteerd, en bij one.com dan weer geïmporteerd. Maar helaas gaat er iets niet goed, maar ik weet niet wat. En ik wil absoluut wel verder met Xenforo, maar ik weet absoluut niet hoe...
 
V

Verwijderd forumlid 175

Guest
Ik heb dus het Xenforo forum verhuist, de files via FTP, en de database heb ik bij de vorige host geëxporteerd, en bij one.com dan weer geïmporteerd. Maar helaas gaat er iets niet goed, maar ik weet niet wat. En ik wil absoluut wel verder met Xenforo, maar ik weet absoluut niet hoe...
Ik ken het controlepaneel en de databasewerking bij one.com . Dat is helemaal anders dan bij een hosting die Directadmin als controlepaneel heeft .Vind one.com trouwens nog heel duur ook.
Hoe krijg ik toegang tot de database met phpMyAdmin?
 

toska

Heeft veel posts
Gewaardeerd lid
Ben daar ook ooit bij geweest op support hoef je niet veel te rekenen, en kennis hiervan hebben ze ook niet?
had hun ooit eens gemaild met een vraag en kreeg als antwoord Beste wij kunnen u helaas niet helpen met dit probleem
en daar stond ik dan.Nogal een geluk dat ik iemand heb leren kennen die zijn vak goed kent.
 

Cédric Vleminckx

Junior lid
@Cédric Vleminckx heb je al eens geprobeerd of een phpinfo.php bestand wel gewoon werkt zoals ik aangaf?
Dat heb ik nog niet gedaan. Wat moet er in dat bestand staan?

Ik heb wel al eens een test script gedownload en op de server gezet, om te kijken als de server wel aan de vereisten van Xenforo voldoet.
En dat was positief, de server bij one.com had alles wat nodig was om Xenforo goed te laten draaien. Dit heb ik ook nagevraagd bij one.com, en dit klopte inderdaad, want ik heb in het verleden nog Xenforo forums bij one.com draaiende gehad. Dus dat zou nu ook gewoon moeten lukken.
Wel was dat telkens met uitzondering dat dit nog nooit met de software van Xenforo 2 was.
 
Laatst bewerkt:
Bovenaan Onderaan